Differences

This shows you the differences between two versions of the page.

Link to this comparison view

raidctl [2013/08/22 12:05]
raidctl [2013/08/22 12:05] (current)
Line 1: Line 1:
 +====== raidctl ======
  
 +  * [[Filesystems]]
 +  * [[NetBSD]]
 +  * [[disklabel]]
 +  * [[fdisk]]
 +  * [[newfs]]
 +  * [[sysctl]]
 +
 +==== fdisk and disklabel ===
 +
 +Assuming the disk device is ''​sd1''​
 +
 +Add a blank partition list:
 +
 +<​code>​
 +fdisk -f -a -0 sd1
 +</​code>​
 +
 +Create a RAID label:
 +
 +<​code>​
 +disklabel -i -I /dev/rsd1d
 +</​code>​
 +==== Initial Setup ====
 +
 +Setup first time:
 +
 +<​code>​
 +raidctl -v -i /dev/raid5 -C /​etc/​raid5.conf
 +</​code>​
 +
 +Display status:
 +
 +<​code>​
 +raidctl -m /dev/raid5
 +raidctl -s /dev/raid5
 +raidctl -S /dev/raid5
 +</​code>​
 +
 +Check if parity is up to date:
 +
 +<​code>​
 +raidctl -p /dev/raid5
 +</​code>​
 +
 +Initialize the parity if it is known to not be up-to-date (used when after a system crash):
 +
 +<​code>​
 +raidctl -P /dev/raid5
 +</​code>​
 +==== Configuration File ====
 +
 +Each configuration file has four required sections, and two optional ones.  They all begin with ''​START''​ and then the section name.
 +
 +First is the ''​array''​ section, which defines the number of rows, columns, and spare disks.
 +
 +A RAID5 array of 1 row, 4 disks and 0 spare disks
 +
 +<​code>​
 +START array
 +1 4 0
 +</​code>​
 +
 +The ''​disks''​ section specifies the actual devices in the RAID array:
 +
 +<​code>​
 +START disks
 +/dev/sd1a
 +/dev/sd2a
 +/dev/sd3a
 +/dev/sd4a
 +</​code>​
 +
 +The ''​layout''​ section defines sectors per stripe unit, stripe units per parity unit, stripe units per reconstruction unit, and the parity configuration to use.
 +
 +This example is from the man page, for RAID5:
 +
 +<​code>​
 +START layout
 +# sectPerSU SUsPerParityUnit SUsPerReconUnit RAID_level
 +32 1 1 5
 +</​code>​
 +
 +Final required section is ''​queue''​. ​ Again, using the man page as a reference:
 +
 +<​code>​
 +START queue
 +fifo 100
 +</​code>​