Differences

This shows you the differences between two versions of the page.

Link to this comparison view

netbsd_pkgsrc [2013/06/11 17:18] (current)
Line 1: Line 1:
 +====== NetBSD pkgsrc (Source Code Installs) ======
  
 +  * [[NetBSD]]
 +
 +  * [[http://​pkgsrc.se/​|pkgsrc frontend]]
 +
 +Install programs onto NetBSD building **from source code**.
 +
 +=== Install NetBSD ports ===
 +
 +Download and install the pkgsrc contents:
 +
 +<​code>​
 +ftp ftp://​ftp.netbsd.org/​pub/​pkgsrc/​current/​pkgsrc.tar.gz
 +tar -zxf pkgsrc.tar.gz -C /usr
 +</​code>​
 +
 +Build package vulnerability database:
 +
 +<​code>​
 +/​usr/​sbin/​pkg_admin -K /var/db/pkg fetch-pkg-vulnerabilities
 +</​code>​
 +
 +<​code>​
 +PATH="/​usr/​pkg/​sbin:​$PATH"​
 +export PATH
 +</​code>​
 +
 +== Build the search database ==
 +
 +This will take a long time.
 +
 +<​code>​
 +cd /usr/pkgsrc
 +make search
 +</​code>​
 +
 +== Build a static list ==
 +
 +<​code>​
 +find /​usr/​pkgsrc/​ -type d -mindepth 2 -maxdepth 2 | grep -v CVS | cut -d "/"​ -f 4- > pkgsrc
 +</​code>​
 +
 +=== Package Source Management ===
 +
 +== Display build options ==
 +
 +<​code>​
 +make show-options
 +</​code>​
 +
 +== Uninstall a package ==
 +
 +<​code>​
 +make deinstall
 +</​code>​
 +
 +== Edit package build options ==
 +
 +Add to ''/​etc/​mk.conf'':​
 +
 +<​code>​
 +PKG_OPTIONS.apache22 = apache-mpm-worker -apache-mpm-prefork suexec
 +</​code>​
 +
 +== Allow vulnerable licenses ==
 +
 +Add to ''/​etc/​mk.conf'':​
 +
 +<​code>​
 +ACCEPTABLE_LICENSES+= vim-license
 +</​code>​
 +
 +== Allow vulnerable packages ==
 +
 +<​code>​
 +echo ALLOW_VULNERABLE_PACKAGES=1 >> /​etc/​mk.conf
 +</​code>​
 +
 +=== Building Packages ===
 +
 +== Run make clean on all dependencies ==
 +
 +<​code>​
 +make clean-depends
 +</​code>​